Slow Server Response

May 16, Thu
Affected Service: Web Services / Hosting
  • Investigating
    A DDOS attack is actively being investigated which is slowing some server response times.

    10:23, May 16 CDT
  • Resolved
    Resolved after DDOS was identified and neutralized. All systems operating normal now.

    17:02, May 16 CDT
Back to current status