Server Upgrades

January 22, Fri
Affected Service: Web Services / Hosting
  • Update
    Some server maintenance and upgrades will cause intermittent disruption on 1/22/20 at 10-11pm CST.

    19:30, Jan 22 CDT
  • Resolved
    Server upgrades complete, downtime less than 3 minutes. Improvements and server upgrades for increased speed, processing, and deliverability.

    23:05, Jan 22 CDT
Back to current status